Service Issue in Platform
Incident Report for Vonage API
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 17:05 UTC
Monitoring
We have implemented a fix for this issue.

Some SMS API customers who are not URL encoding their form bodies may have experienced truncation of their SMS messages if the SMS content contains a comma. Customers are advised to URL encode all fields when submitting requests to avoid incorrect handling of their messages.

The impact happened between 20 June 2022 09:56 UTC and 20 June 2022 15:53 UTC. It is now fixed.

The list of services that were impacted have been confirmed as:
SMS API for HTTP customers only

SMPP customers are not impacted.
We will continue to monitor the service during the next few hours and post updates should anything change.
Posted Jun 20, 2022 - 16:24 UTC
Update
Our engineering team continues to work on the issue with SMS message truncation. We will provide another update as soon as the issue is fixed.

Some SMS API customers who are not URL encoding their form bodies are experiencing truncation of their SMS messages. Customers are advised to URL encode all fields when submitting requests to avoid incorrect handling of their messages.
Posted Jun 20, 2022 - 14:27 UTC
Identified
The issue has been identified and our team is working on the fix. We will update as soon as the fix is completed.
Posted Jun 20, 2022 - 14:10 UTC
Investigating
Our monitoring has alerted us to a potential service issue with our platform where some customers may experience SMS message truncation if the SMS content contains a comma.

Below products are likely to be impacted:
SMS API for HTTP customers only

SMPP customers are not impacted.

We aim to provide an update on our investigation within 1 hour.

Please see this article - https://help.nexmo.com/hc/en-us/articles/360015693092-Nexmo-Incident-Handling - for an explanation of our approach to publishing incidents.
Posted Jun 20, 2022 - 13:45 UTC
This incident affected: SMS API (Outbound SMS).